请选择 进入手机版 | 继续访问电脑版
设为首页收藏本站

QQ协议_QQ机器人_webqq_QQ空间-Q协论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 3462|回复: 0

易语言QQ号到Hex文本

[复制链接]

5

主题

0

好友

79

积分

注册会员

Rank: 2

发表于 2017-1-25 14:36:14 |显示全部楼层
.版本 2

.子程序 生成16进制_QQ号, 文本型
.参数 号码, 文本型
.局部变量 a, 文本型
.局部变量 n, 长整数型

n = 到数值 (号码)
a = 查看字节集_asm (到字节集 (n))
返回 (反写字节集 (取文本左边 (a, 11)))
.版本 2

.子程序 查看字节集_asm, 文本型
.参数 字节集, 字节集

.如果真 (字节集 = {  })
    返回 (“”)
.如果真结束
返回 (删首尾空 (_查看字节集ASM (字节集)))

.版本 2

.子程序 _查看字节集ASM, 文本型, , 未加空字节集判断
.参数 字节集, 字节集
.局部变量 返回文本, 文本型
.局部变量 tab表, 文本型


tab表 = “000102030405060708090A0B0C0D0E0F101112131415161718191A1B1C1D1E1F202122232425262728292A2B2C2D2E2F303132333435363738393A3B3C3D3E3F404142434445464748494A4B4C4D4E4F505152535455565758595A5B5C5D5E5F606162636465666768696A6B6C6D6E6F707172737475767778797A7B7C7D7E7F808182838485868788898A8B8C8D8E8F909192939495969798999A9B9C9D9E9FA0A1A2A3A4A5A6A7A8A9AAABACADAEAFB0B1B2B3B4B5B6B7B8B9BABBBCBDBEBFC0C1C2C3C4C5C6C7C8C9CACBCCCDCECFD0D1D2D3D4D5D6D7D8D9DADBDCDDDEDFE0E1E2E3E4E5E6E7E8E9EAEBECEDEEEFF0F1F2F3F4F5F6F7F8F9FAFBFCFDFEFF”

返回文本 = 取空白文本 (取字节集长度 (字节集) × 4)
置入代码 ({ 139, 69, 8, 139, 117, 252, 139, 93, 248, 139, 56, 139, 79, 4, 131, 199, 7, 71, 51, 192, 138, 7, 141, 4, 70, 138, 16, 136, 19, 67, 64, 138, 16, 136, 19, 67, 198, 3, 32, 67, 226, 231, 139, 69, 248, 201, 194, 4, 0 })
返回 (“”)

.版本 2

.子程序 反写字节集, 文本型
.参数 文本型字节集, 文本型
.局部变量 a, 文本型
.局部变量 i, 整数型
.局部变量 c, 文本型, , "0"
.局部变量 n, 整数型


c = 分割文本 (删首尾空 (文本型字节集), “ ”, )
n = 取数组下标 (c, )
.计次循环首 (n, i)
    a = a + c [n - i + 1] + “ ”
.计次循环尾 ()
返回 (删首尾空 (a))


回复

使用道具 举报

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

Archiver|手机版|Q协论坛 ( 苏ICP备10054835号-2   互联网安全

GMT+8, 2022-8-9 09:22 , Processed in 0.314792 second(s), 29 queries .

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

回顶部